UPD: Solved. The issue was because we are using nginx like a frontend. So nginx does not pass the HTTP_HOST to apache.


Hello there!

I am getting an issue with getting subdomain parameter during my base controller on the production server during the localhost it's ok. other parameters from url like controller, action came back because they should.

this returns null on production:

$agencyName = (string) $this->_getParam('agency')

no changes designed to .htaccess:

RewriteEngine On

RewriteRule ^primary - [L,NC]

RewriteCond % -s [OR]

RewriteCond % -l [OR]

RewriteCond % -d

RewriteRule ^.*$ - [NC,L]

RewriteRule ^.*$ index.php [NC,L]

and here's my vhost configurations:

<VirtualHost *:8080>

        ServerName  agencies.domain.com

        ServerAlias *.agencies.domain.com

        ErrorLog /var/log/apache2/agencies.domain_errors.log

        DocumentRoot /var/world wide web/agencies.domain.com/public/

        <Directory "/var/world wide web/agencies.domain.com/public">

                Options -Indexes FollowSymLinks Includes

                DirectoryIndex index.shtml index.php

                AllowOverride All

                # Controls who are able to get stuff out of this server.

                Order allow,deny

                Allow all

        </Directory>

</VirtualHost>

Does anybody knows why it happenes?

upd:

hubs in Bootstrap

public function run()

    

company, I actually do have $config['siteUri'] defined i attempted using :agency.domain.com obtaining the same issue again

Make use of the following :

class Bootstrap stretches Zend_Application_Bootstrap_Bootstrap





Should you give a valid subdomain (ie. only composed of figures a-z0-9), it will likely be passed in agency, otherwise then agency won't be set. (A minimum of it really works for me personally using ZF 1.11.3 :p).

Solved. The issue was because we are using nginx like a frontend. So nginx does not pass the HTTP_HOST to apache.